RPi-Monitor Installation

Installation using the repository

RPi-Monitor is using github as debian repository. This repository will make installation and update of RPi-Monitor accessible with the command apt-get or aptitude.

To use this repository follow the instruction bellow:

Execute the following command to add RPi-Monitor into your list of repository:
 

    sudo wget http://goo.gl/vewCLL -O /etc/apt/sources.list.d/rpimonitor.list

Install my public key to trust RPi-Monitor repository:

 sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2C0D3C0F


To install RPi-Monitor, execute the following command:

    sudo apt-get update
    sudo apt-get install rpimonitor

To upgrade RPi-Monitor, execute the following command:


    sudo apt-get update
    sudo apt-get upgrade


After installation you should excute the following command to update information about upgradable packages:

  sudo /etc/init.d/rpimonitor update

Manual installation

Download the latest package from the official repository in Github with the following command (replace latest_package_url by the real url fond on github):

    wget latest_package_url -O rpimonitor_latest_all.deb

If you have issue with GnuTLS: A TLS warning alert coming from Github you can download it with the following command:

    curl -L latest_package_url -o rpimonitor_latest_all.deb

Install the dependencies by executing the following command (use command apt-get if aptitude is not available on your target system):

    sudo aptitude install librrds-perl libhttp-daemon-perl libjson-perl libipc-sharelite-perl libfile-which-perl

Installation or upgrade can be done with the command:

    sudo dpkg -i rpimonitor_latest_all.deb

Complete the installation with the command:

    sudo apt-get update && sudo /usr/share/rpimonitor/scripts/updatePackagesStatus.pl

Uninstallation

To uninstall RPi-Monitor, you can execute the following command:

    sudo apt-get remove rpimonitor

or:

    sudo apt-get purge rpimontor

7 comments :

  1. Complete the installation with the command:

    sudo apt-get update && sudo /usr/share/rpimonitor/scripts/updatePackagesStatus.sh

    Shouldnt it be .pl not .sh? :)

    ReplyDelete
  2. Thank you for the great installation tutorial and the amazing monitoring tool :)

    ReplyDelete
  3. Great app and I love it! Now, the only question that I have is package upgradable is showing that there is 1 item to upgrade. How does that happen?

    ReplyDelete
  4. Hello Xavier,


    i tried to install the RPi Monitor on a Raspberry PI 2 according to your installation guide here and using the manual mode.
    But it gives me an error at the end calling dpkg. See the extract from terminal:
    >pi@raspiccuhis2:~ $ sudo dpkg -i >rpimonitor_2.9.1_all.deb
    >dpkg-deb: Fehler: »rpimonitor_2.9.1_all.deb« ist kein >Archiv im Debian-Format
    >dpkg: Fehler beim Bearbeiten des Archivs >rpimonitor_2.9.1_all.deb (--install):
    >Unterprozess dpkg-deb --control gab den Fehlerwert 2 zurück
    >Fehler traten auf beim Bearbeiten von: >rpimonitor_2.9.1_all.deb

    Unfortunately it is in German, but it means that the archive is not an archive in Debian format.

    Any ideas ?
    Should RPI Monitor run as well on Raspberry Pi 2 ?


    Regards
    Ralf

    PS: I installed some months ago you RPI Monitor on an old Raspberry Pi B and it worked properly.

    ReplyDelete
  5. Can someone please show me an example set of lines to make friends work in 2.10? I have tried just about everything in the rpimonitord.conf file and I do not even see the link in the upper right corner.

    Thanks

    ReplyDelete